24.01.2018
  • Betrifft Modul
  • pdf
  • Meldezeitpunkt
  • Donnerstag, 13.02.2014 14:49
  • Letzte Änderung
  • Freitag, 26.02.2016 18:58
  • Status
  • Neu
  • Bearbeiter
  • Noch nicht zugeordnet
  • Text
  • Mein PDF Modul erzeugt nur leere Seiten. Im Log hab ich folgende 2 Fehler:

    LS Error: SQL-Failure. Database respondet: <b>You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near '%prefix%party_user AS party ON user.userid=party.user_id WHERE user.type > -1 AN' at line 2</b><br /><br />Query: <br /><i>SELECT user.*, clan.name AS clan, clan.url AS clanurl FROM ls_user AS user LEFT JOIN ls_clan AS clan ON user.clanid = clan.clanid LEFT JOIN %prefix%party_user AS party ON user.userid=party.user_id WHERE user.type > -1 AND party.party_id = 1 AND (1 = 0 OR user.type = 1) ORDER BY username, name ASC</i><br />

    SQL-Failure. Database respondet: You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near '%prefix%party_user AS party ON user.userid=party.user_id WHERE user.type > -1 AN' at line 2Query: SELECT user.*, clan.name AS clan, clan.url AS clanurl FROM ls_user AS user LEFT JOIN ls_clan AS clan ON user.clanid = clan.clanid LEFT JOIN %prefix%party_user AS party ON user.userid=party.user_id WHERE user.type > -1 AND party.party_id = 1 AND (1 = 0 OR user.type = 1) ORDER BY username, name ASC

    Er löst also das prefix nicht auf. Jemand eine Idee woran es liegt?

    EDIT: Habe jetzt die Datei /modules/pdf/class_pdf.php geändert und anstatt %prefix% vorübergehend mit ls_ ersetzt. Sollte aber natürlich ne schönere Lösung geben

Kommentare
     
    Pimmal
    11.03.2014 08:22
    Habe das selbe Problem es werden nur leere Seiten generiert, aber das %prefix% problem habe ihc nicht und daran liegt es scheinbar auch nicht, da bei mir in den SQL Abfragen ls_ kein Problem ist. quote
    byte
    11.03.2014 10:40
    Ich bräuchte mal den genauen Link bei dem das Problem auftaucht. Bei mir funktioniert alles. Also welche Modul und welche Aktion mit welchen Parameter aufgerufen werden.

    Wobei ich sagen muss.. das PDF-Modul müsste auch dringend überarbeitet werden. Das is alt und ziemlich umständlich zu bedienen. Ich hab bei uns mal was mit RTFs für die Urkunden eingebaut. Sprich.. Urkunden werden bei uns automatisch generiert. Evtl. kann man das System übernehmen.

    --
    www.synergy-lan.de
    Wir verleihen günstig Strom & Netzwerkequipment an kleinere Lans (bis 150 Teilnehmer)
    99Euro für 7x24Port Clientswitche + Gigabitbackbone (Dualgig-Uplinks) / WE
    Andere Kombinationen auf Anfrage.
    quote
    Pimmal
    11.03.2014 10:46
    http://www.netsession.net/index.php?mod=pdf

    Das mit den Urkunden wäre auch fein :-)
    quote
    MaLuZ
    24.02.2016 10:17
    Habe gerade http://www.tcpdf.org/ gefunden.
    Das scheint durchaus einen Blick wert zu sein, da man auch direkt HTML ins PDF packen kann.
    Somit könnte man auch das übliche Template-System dort einbinden, oder WYSIWYG über den FCKEditor versuchen
    quote
    eisbaer
    25.02.2016 20:21
    Also das Modul aus der LIB. http://fpdf.de/ Funktioniert bei mir in der 1.81 Version zuminderst mit den Beispielscript auf meinem Server.
    Im Moment schaue ich gerade das ich die Abfrage wieder als PDF-Modul erzeugen kann.

    quote
    MaLuZ
    25.02.2016 22:17
    Dann ist das Framework sogar besser, wenn es schon läuft

    Dann sind ja bald die gröbsten Probleme mit der aktuellen Version durch.
    Ich witter ein neues Release am Horizont...
    quote
    eisbaer
    26.02.2016 18:58
    Wer auch etwas damit Spielen will.

    http://fpdf.de/downloads/addons/10/

    quote
    7 Einträge
    • Hinweis:
      Bitte loggen dich ein, bevor du einen Kommentar verfasst
    • Hinweis:
      Es wurden keine Einträge gefunden